K hromadnému rozesílání textových zpráv je nutné mít telefonní čísla včetně předvolby a bez mezer.

V případě, že má vaše databáze jiný formát telefonních čísel, můžete ji jednoduše upravit dle následujících pokynů:

1. Otevřete si databázi v excelu. Pokud máte vyexportovanou databázi v CSV, nejprve ji převeďte do excelu.

2. Nejprve odstraňte mezery mezi jednotlivými čísly tak, že si označíte sloupec s telefonními čísly a dáte najít a nahradit.

3. Do kolonky "najít" napíšete mezeru a kolonka "nahradit" zůstane prázdná. Poté kliknete na "Nahradit vše".

4. V tuto chvíli máte telefonní čísla bez mezer. Je však možné, že některá čísla již předvolbu +420 mají, ale ostatní nikoli. Označíte tedy opět sloupec s čísly a změníte formát na speciální formát Telefonní číslo.

5. Nyní máte telefonní čísla devíti až dvanáctimístná bez + před předvolbou.

6. V dalším kroku si přidáte nový sloupec s telefonními čísly, kde budou čísla ve správné podobě a vytvoříte jednoduchou rovnici.

U prvního čísla ve sloupci, kde chcete mít telefonní čísla ve správném formátu, napíšete = a postupně vkládáte funkce, aby byly podchyceny podmínky s délkou 9 i 12 čísel. Do prvního políčka můžete s novým číslem nakopírovat následující funkci:

=KDYŽ(DÉLKA(D2)=9;CONCATENATE("+420";D2);KDYŽ(DÉLKA(D2)=12;CONCATENATE("+";D2)))

D2 je třeba nahradit buňkou, kde je první telefonní číslo, které chcete upravit. Pakliže máte D2 nahrazeno správnou buňkou, stačí stisknout klávesu Enter.

Pozor! D2 je třeba nahradit 4x!

V případě, že se jedná o telefonní čísla mimo ČR nahradíte +420 předvolbou daného státu.

7. První telefonní číslo má již správnou podobu, ale je třeba, aby se zkopírovala i všechna ostatní čísla. Toho docílíte tak, že chytnete první buňku a přetáhnete přes celou databázi.

8. Právě máte veškerá telefonní čísla úspěšně připravená k importu do Ecomailu.

Jak telefonní čísla naimportovat do své databáze v Ecomailu?

Postup je jednoduchý. Jen je třeba telefonní číslo importovat spolu s e-mailem daného kontaktu. V opačném případě se číslo nenaimportuje. Není možné importovat pouze telefonní čísla. 

V případě, že máte nachystanou databázi podle výše zmíněného postupu, stačí už jen následující:

1. Označte veškeré sloupečky CTRL+A a připravte k překopírování CTRL+C.

2. Otevřete si seznam, do kterého chcete kontakty naimportovat a pomocí CTRL+V překopírujte z excelu kontakty do kolonky.

3. Po importu již stačí správně pojmenovat sloupce. Sloupec s telefonními čísly v nesprávném formátu vynechejte.

V případě, že svou databázi pouze aktualizujete a nenahráváte zcela nové kontakty, zadejte "U nalezených kontaktů aktualizovat údaje" a k již existujícím e-mailovým kontaktům se vám připíší telefonní čísla.

 

Nyní máte správně naimportovanou databázi kontaktů včetně telefonních čísel a můžete zaslat svou první SMS kampaň

Našli jste odpověď?